Поиск по этому блогу

понедельник, 8 декабря 2014 г.

Установка redmine 2.4

Про полную установку писать не буду (потом возможно допишу, но сейчас нет времени).
Итак проблемы которые меня постигли на ubuntu 14.04.

1) Не установился gem mysql2
Текст ошибки примерно следующий
An error occurred while installing mysql2 (0.3.17), and Bundler cannot continue.
Make sure that `gem install mysql2 -v '0.3.17'` succeeds before bundling.
Я попытался установить пакет без указания версии
gem install mysql2
 Но ничего не изменилось
Лечение:
sudo apt-get install libmysqlclient-dev

2) Не установился gem  rmagick
Текст ошибки
An error occurred while installing rmagick (2.13.4), and Bundler cannot continue.
Make sure that `gem install rmagick -v '2.13.4'` succeeds before bundling.
Лечение
sudo apt-get install imagemagick
sudo apt-get install libmagickwand-dev

После этих действий мы увидим заветные строки
Your bundle is complete!
Gems in the groups development and test were not installed.
Use `bundle show [gemname]` to see where a bundled gem is installed.

Комментариев нет:

Отправить комментарий

Количество·просмотров